createXOPObject always returns null

pub.soap.utils:createXOPObject always returns null. Im passing input as stream. Find attached the code snapshot
Ive tried for xml as well as pdf files.

Options tried - didnt work out
set encoding = autoDetect



We are also facing same issue in creating XOPobject. Was this issue solved?

Any leads into this?


After some more research we finally figured out that XOP object is not visible in the pipeline. So we will always see XOP object as null while debugging.But at run time data will get populated in the XOP object, only that it will not be visible to us.
One important point is to have watt.server.SOAP.MTOMStreaming.enable=true in the Extended settings of the IntegrationServer when dealing with XOP object. The streaming will then be taken by IntegrationServer itself.

Found the below info from a different SI… This should explain why you see ‘null’ as output.

“The xopObject is shown as null in Developer/Designer since object serialization/de-serialization of XOP objects is currently not supported in IS 8.2 as a whole. This is just an issue of displaying the object in the Developer/Designer tools and does not affect the functionality.
E.g. when exposing the service (with xobObject variable as output) as a web service, IS 8.2 does return a proper non-null value.
So this is not a product bug issue but a current restriction of wM 8.2 implementation.”


Im facing strage issue.In one environement when im using this xopobject it’s returning the attachent size and pdf also opening.But in another enviornment for the same file but im receiving attachment size as zero. It’s simple webservice which will return pdf as attchement.Please help me out to resoolve this issue