Configuring JDBC adapter connection

I am new to webMethods. I am trying to configure my JDBC Adapter configuration. But I am unable to do it. Here is the steps I do,

  1. Go to
  2. Adapters
  3. webMethods Adapter for JDBC
  4. Configure new connection
  5. webMethods Adapter for JDBC connection

I fill up all the details and I enable the connection. I get the following error as soon as I enable the connection:

Error encountered

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource MyTestPackage.adapters:myTestAdapter.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.200] The JDBC DataSource class “oracle.jdbc.pool.OracleDataSource” cannot be located.

Please help.

Based on your oracle version, place corresponding jar file ( ojdbc14.jar or ojdbc6.jar ) under WmJDBCAdapter/code/jars location. Restart IS and check.



what is your oracle server version?
waht is your exact wM Version as well as JDBC Adpater version?

For all wM Versions starzting with 9.x you should use latest ojdbc6.jar or ojdbc7.jar (available since Oracle 12) and place it where MR has described.
Reloading the package should be sufficient.

For further informations check for JDBC Adapter Documentation available from here:



I tried the same but got the same error. I am attaching the screenshots…hope you could get a larger view about the issue.


Hi Subhajit,

please make sure that you have placed an ojdbc6.jar or ojdbc7.jar under WmJDBCAdapter/code/jars/ and have reloaded the package from IS Admin UI.

If this does not help check the Conenction configuraiton (as in web.png) for any leading or trailing spaces and remove those.

You can try to explore the server.log for this instance as the error message might be easier to check to additional spaces there.


Hello Subhajit,

Network protocol=tcp is missing.

I would suggest you to read and understand the JDBC adapter guide before setting up JDBC connection. There is a chapter that clearly talks about this.

Error states that it is unable to locate the class. Keep the right jar as specified , reload the package.



I did the same again as told by you all. Now, its showing a different error which I am unable to diagnose. I have attached the screenshot here.


Either your DB listener is not up or you are not passing the correct db name. Check your configurations again.

I would request you to please use either TOAD or SQL Developer to connect to the DB server and check the connectivity.