Communication Problem task engine - process engine

Dear all.

I have the following problem: I have a simple process with a task. The task gets called, data is correctly transfered, then a user works with the task and commits the form. No errors, but the process is not executing from this point on. Problem is that the task’s status is set to “Started” in the Process Instance view, but opening the tasks shows that it’s status is “Completed”. So on the one hand I have a started task in the process, on the other hand i have a completed task. It seems to me that the task engine is not reporting back to the process engine that the task has been finished. Can someone give me a hint? I have created a couple of distinct processes with task and had this problem in each of them!!!

Can someone help me?

Thanks in advance

Henning

No hints? Please?

Hi Henning, do you know how to solve this now? I see the same error as you, could you please tell me how to solve this?

what version webmethods are you using? i had the same problem before.If you are running on 7_1_1 you need to apply TE_FIX4. If you chane the default Administrator password in IS you hit this issue, password decryption bug. let me know if you need more details.

thanks,
vijay

Hi ashitosh:

thank you very much for your reply.
Actually I have solved this, and I found this was caused by a bug in webMethods setting document. In that document it gives wrong sample connect str. And it caused the fail connection from task engine to Process engine. It is OK after I corrected the conn str.

Anyway, still many thanks for your reply!

hi jacky,

what webmethods settings document are you refering to?
(i have the same problem)

thanks

Hi bogdan:

Sorry for my late reply. And I don’t know if you have solved your problem
Actually I referred to wM webMethods_Installation_Guide_7_1_x.pdf.
in this document it tells to use the conn str http://localhost…
but actually you should remove “http://” and just use localhost
that is the reason.
hope this can help you!
:slight_smile: