Command Line Java Service fails

We are trying to use the Ws_Pro FTP client for SFTP communication to the external Partners.
we are using a Java service in webMethods (Windows Environment)to make a system call to execute the command to communicate to external SFTP server.
The command works fine when we run on command prompt , but when we try to pass the same command to Java service , we see the destination parsing error.
EX:cmd.exe /c E:\HRIS\wsftppro.exe -s local:E:\HRIS\From\FI.txt -d ftpRt:
The above mentioned command works fine when we exceute on command prompt .This will take the file from local E drive and place the file at the destination site(ftpRt). This tool has got a facility to create a site meaning a connection and save the connection , similar to any tool like WinSCP etc.
Please let us know if any body has any information like why the Java service fails where the same command is working on command prompt.

What is the error that you are seeing? What version of the IS is this issue on? Are you using the WM provided util service to execute the command or is it a custom java service?

Did you try to put this command in a bat file and execute it using the java service?


Hi Akshith,
Thanks for quick reply !

[FONT=Helv][SIZE=2][FONT=Helv][SIZE=2]webMethods Environment details
: [B]Operating System: Windows 2003
: Application: webMethods Integration Server 7.1.2

We are using the custom Java service , but it is exact copy of the "makeSystemCall " Java service provided in PSUtilities.
We see an error as “Destination Parsing Error”

Did you add the file location to the list of allowed paths and the command to the list of allowed commands? There should be a property file in the config directory of the PSUtilities package.

Also on a separate not, try to put the same command in a bat file and run it from webMethods.



The cmd.exce /c command is alreadya dded into the config file in the PSUtilities. Suprisingly the command works fine when i give the userName and Pwd as part of the command :
For Ex: cmd.exe /c E:\HRIS\wsftppro.exe -s local:E:\HRIS\From\FI.txt -d ftp://:@:21/ — This command even works fine from Java Service, but when i give the site details instead of userName, Pwd the command doesnt work through the Java service (cmd.exe /c E:\HRIS\wsftppro.exe -s local:E:\HRIS\From\FI.txt -d ftpRt: – This doesnt work)

I had written the standalone Java service(Java service not from webMethods) and passed the same command it worked fine .The file has been picked and placed at the target location .But when i run the same Java service from webMethods it fails with “Destination Parse error”

Hi all,

We could solve the problem now.
The problem is, when we create sites in ws_ftp pro, they get stored in the below file.

C:\Documents and Settings\xxxxx\Application Data\Ipswitch\WS_FTP\Sites\ws_ftp.ini

Here xxxxx is the user name you have logged in.

The problem is my sites are located under my user name say xxxxx, where as wM uses SYSTEM as the username when it runs the ws_ftp.

What we did is, we created a folder SYSTEM in C:\Documents and Settings and copied all the ApplicationData folder in it.

Now my java svc through wM also works.

Not sure if there is any better way to resolve this issue.
We are also wondering, wht we need to configure in ws_ftp pro so that the sites created by a user are visible to every one.
Currently, the sites created by a user are visible only to that user.