There was a post earlier about this, but not much of a response.

When I perform thousands of small/fast updates and inserts I occassionally get a TCommunicationException. I cannot find this exception in the documentation. I would like to catch it and retry the operation, but it does not seem to be thrown by the offending function.

Any information would be helpful.




Do you have the XML Starter Kit Tamino or you have a full licenced one? This is important because if you have the tryout version there are several limitations like sessions number or database size that could generate unexpected errors.

Just out of interest which JDK are you using? And on what platform? I have heard that JDK 1.4 fixed a few problems in the HTTP library. I.e. have you tried the latest JRE 1.4?

Full licenced version.

1.3.1 on IRIX

I have not tried the latest jre. I am somewhat hesitant to install 1.4 on our SGI because I am unsure whether they will live together well.

I would have thought that you have a better chance of them co-existing on a Unix box than Windows.

Mind you - the more modern JREs/JDKs seem to default to “versioned” directories. This is even true for Windows. You could always try a “custom” installation to your HOME directory - i.e. installing without privileges.