Clarification Reg Pub.Storage services(Locks Acquired not released)

Hi,

i’m having a small clarification, we are using pub.storage services in some of our integrations.

recently those services are not wrking i mean throughing errors this is becoz there are 2 Locks on datastore which remained UNLOCKED from the month of Jan-09

this i saw when i manually run pub.storage.listlocks :when i run this service i saw 2 locks which were there…

then i tried to unlock them using pub.storage.releaselocks service…but i donno y the Locks has’t been released…
i donno y its not working?

and i even read the PDF that no lock can stay for more than 3 minutes but i wonder how these locks have been not unlocked(from long time)

COuld any plz help me on this…

i dont have much idea on this…
atleast try to suggest some thing on this.

Regards,
Sujit

It seems a deadlock due to poorhandling of the threads. Check if any services are still running that access these services in admin console -> service usage. The resolution may be a system restart in the worst case. Typically these storage services use HashTable and the implementation blocks will be thread safe. I suggest you can write your own efficient java services for such things.

Cheers
Guna

Unfortunately even after multiple restarts the locks have not been opened…:confused: