Certificate Toolkit

Hi,

I am using certificate tool kit 7.1 which I downloaded from Software AG website and following the instructions in the certificate toolkit guide documentation, running into issues when trying to execute the first step which is ssltoolkit.bat.I am getting the following error:
D:\SoftwareAG_1\IntegrationServer\CertificateToolkit>"…\jvm\win150\jre\bin\java" -ms16M -mx32M -classpath .\LIB\ssltoolkit.jar;.\LIB\certkit.jar;…\comm
on\lib\ext\enttoolkit.jar" com.wm.app.certkit.CertStarterKit
The system cannot find the path specified.

I am just wondering, Do I need to configure anything else to make it work. Could any one please help.

Thanks,
Chandra.

Hi,

Actually, A flat file is coming from the customer to webMethods. I am creating the flat file schema.The content of the files has a Header line, detail section with Multiple records and a footer.The thing is the fields in the header are comma separated and the records in the detail level are fixed length and eventually the footer fields are again comma separated.The records inside the detail starts with and I am providing the same exact value in the record definition to match when I am creating the schema to validate.But when I ran the schema from the developer providing the data in the format i mentioned above, even though i am providing the detail level to match in the file as I am providing that value in the record definition it is taking from the header and mapping those header values in the detail section when i am generating the IS document from the flat-file schema which is causing an issue.
it is as follows:
this input file is coming with
Header–> Comma separated
detail → fixed length
Footer–> Comma separated.
I am just wondering,is it a valid way to send the file with two different formats as in this case Comma separated and fixed length. and it looks like the customer prefers that format.
I am under the impression that having one flat file schema and defining the record definition as it is to match the detail level in the file will take care of it reading the file from the detail level ignoring the header. Or Do I need to have 3 schemas ( one for header, one for detail, one for footer) and take care of them separately. Or Do I need to remove the header/footer from the file by using the built in services if they have some in webMetods.Or Do I need to write a java service? Could anyone please advise

Thanks,
Capri_lak

Hello Chandra,
Yes,i think it might be refferring wrong java path,I think you need to correct that and start the certificate tool kit.It should work.

Thanks & Regards,
Venkata Vidya Sagar Pokuru:rofl:

I am creating a FlatFile Schema based on the information provided by the source sytem.
They did specify the type of the field(Char/numeric).In the schema Under Record definition I am creating the Field definitions accordingly to the specification document.I am just wondering, Can we perform a test by running the file with source data against the
Schema we have to validate the DataTypes coming in or Do I need to handle it in the flow service?
By the way I used the Validator Property and i tested with sample data and it worked the way it supposed
to be.In the similar lines I am just wondering can it be done to vaildate the data types?
I do see in the properties tab property called DataType but I wasnt able to figure it out and documentation didnt provide me enough information .Could you please advise.

Thanks,
Capri_lak.