Certficate Upload Acces Denied

I want to Upload A Certificate but it always says Access denied!!
I tried the same thing with an Admin Account and it is the same Problem Acces Denied!!

I need your Support on this one
Thank you

Can you verify that your user has these?

See also: Cumulocity IoT - OpenAPI Specification

Use Dev tools to see what call is getting the error. It’s likely you haven’t got the correct permissions as Christoph suggests.

Hi Christoph,

We have another user that is having the same problem when adding a certificate. The user tried with an admin account and still gets “Access Denied” messages. Can you please advise on a possible solution?


What does Dev tools show ‘Access is denied’ to?

I can add a cert to this tenant using ‘UniversityRelations’ user. It’s got TENANT_ADMIN permission.

‘Faculty1’ certainly does NOT have the correct permissions.

Note, the admins group does NOT have the required permissions.

At least on my test tenant, the only out-of-the-box group which includes the ROLE_TENANT_MANAGEMENT_ADMIN role is “Tenant Manager”.

1 Like

As Reuben pointed out, the default admins group does not have the required permissions. You can check what you have in the UI:

What you are looking for is “Tenant management”.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.