CentraSite Repository errors during startup

We are running community CentraSite 9.5 and believe our VM took a hit during an outage. Now when trying to start up the repository we are getting the following immediately after running startup.sh…we are searching everywhere trying to understand what this means. Any ideas anyone?

/opt/Centrasite/CentraSite/bin > startup.sh
INODST1751: Start of CentraSite server startup processing version 9.5 on Linux x86_64
INODSI2271: Start server ‘CentraSite’
INODSE1130: System error 22 occurred during semaphore operation
INODSE2169: Received response 38 (82) while starting server
INODSF1436: Terminated with errors

Thanks, Diane

Hi Diane
please check the data directory if there was a *.txt file created which might tell a further reason.
But the hint about the semaphore - is there still a inosrv process running?

I checked /opt/Centrasite/CentraSite/data and the only .txt file is from 9/8 and the last lines in it are from when it was started on that date.

I also double checked for the inosrv process and it is definitely not running, I had thought of that also. Is there a semaphore file that is created when it’s started by any chance that needs to be deleted that you know of?

Hi Diane,
Semaphones from CentraSite can be found by issuing the command ipcs and looking for ones with the key starting with ‘0xb2c’.
If you have no processes that start with ino running (ps -ef | grep ino) and you see ipc resources, then issuing the command ipcrm -s you can delete the semaphones - you may need sudo/root writes to do this.

If this does not help, then we may need to look in more details.

Ok, we had 2 semaphore keys and had the 1 starting with ‘0xb2c’ deleted by our Linux admin guy. Tried starting and still get the same errors. I’m assuming we only needed to delete the 1? This is what we get from issuing ipcs:

------ Shared Memory Segments --------
key shmid owner perms bytes nattch status
0x00000000 4718593 root 644 80 2
0x00000000 4751363 root 644 16384 2
0x00000000 4784132 root 644 280 2

------ Semaphore Arrays --------
key semid owner perms nsems
0x0aaa0001 32769 svcwmadmi 666 1

------ Message Queues --------
key msqid owner perms used-bytes messages

Hi Diane,
Delete the one with 0x0aaa0001 as well. If the DB then does not start, then we probably should do an online session with you.