Can't register North American Ewon Flexy to Cumulocity

Product/components used and version/fix level:

Flexy 205

Detailed explanation of the problem:

I’ve tried using three separate North American based Ewon’s for this and have had no luck with any of the three. All three flexy’s have different firmware, but they are above the suggested requirement. I’ve followed all directions, tried different methods, looked up different forums, but have not had any success. My colleague in Europe had success with devices in Europe to our tenancy, but as soon as they tried to connect the same North American devices I was attempting to work with before, they did not have any luck either. We did ensure that the Host on the connectorconfig file reflected the appropriate “.us.”, as we believe this would be the only change in that file. The other two files, and all other lines of cone in the connectorconfig json, remain the same.

Error messages / full error message screenshot / log file:

“Wait for connection”

Question related to a free trial, or to a production (customer) instance?

Can you add the connectorconfig file?