Can i download the .process file from MWS

Hi,

I have admin access to MWS, IS and Designer. I want to download the prcess model to my local. Is there any way we can do the same?

MWS and IS only hold the “compiled” executable version of the process. The process “source” is not stored on the server. When developing a project, the procect source os stored in a project in the Designer workspace. Usually this is versioned into a source control system. Processes can also be exported and imported from and to designer.
So you need to get it from the place where the process projects are stored in your company or contact the original developer to give you a copy of the source project.

Hi,

I think it is also possible to retrieve the process definition from the database. ProcessEngine schema contains table WMPROCESSDEFINITION, which contains column PROCESSFILE - this column is BLOB type and it contains process definition, which is stored by SoftwareAG Designer as *.process file. So, it should be possible to retrive content from this column and save it as <process_name>.process file - and this file can be imported to SAG Designer.
You have to remember, that in addition to .process file, you need also IS packages which are dedicated for this process - those packages can be exported from IS directly and moved to your development environment.

This approach is of course the trick, and it is better to download the process and its sources from the central repository (SVN) where these artifacts should be stored.

RGDS,

Hi Lance,

As Slawomir advised, You can retrieve latest process file from WMPROCESSDEIFINITION table order by deployment version.

Best
~Raj

Hi, There is a column in WMPROCESSDEFINITION table. I copied the content and saved as .process file. Tried to open the same file in the Designer to check if i am able to see the process model. But i could not see anything. Its blank. Am i doing in a right way? Could someone advise

Column name is PROCESSFILE

http://webmethodstipsexplored.blogspot.in/2010/12/want-process-model-which-is-running-in.html

may I know which tool you are using to view the table ?

Hi lance,

i enclosed few imgs (db is oracle), double click that blob field and copy the contents as it shown in second img, paste in normal editor save as .process, i bet it will work :slight_smile:

Best
~Raj
pic1.PNG

Hi All,

Thank you!! Its worked.

Glad That it worked for you :slight_smile: