Calling SOAP Service From Natural Unix using Proxy doesn't w

Hi all,
I’ve Natural version installed under Unix AIX 5.2. I created a Natural program calling a SOAP Service over Internet. In order to access internet from our Unix and Windows Machine we’ve to specify a Proxy server and a specific port.

Running the Program under Natural Windows Xp (that inherit proxy conf from the system) works correctly and I’m able to reach the INternet Web Service.

Under Unix, I configured the PROX parameter in Natparm and I tried to run the same program. Every time, after waiting several seconds, I get a NAT8304 HTTP request failed. Reason : -1004:.

It looks like Natural is not using the proxy, infact running the same program from a unix machine that doesn’t need the proxy to reach Internet works fine. If I specify the PROX parameter on this machine , the program continues working fine due to it ignore the proxy setting in natparm (I specified a wrong proxy and everithing worked).

Is this a known issue or I did something wrong ?

Best Regards
Gianluca Ancilli