BytesToString returning "" string

Any idea to how can i send it without uploading it to public? i probably can send one to @John_Carter4 too

You can upload it to a private space (say, your Google Drive) and use the Message feature to send us the link -

Click on our profile and select Message -

Then add our usernames and send us the message; I’ve sent you a test message -

KM

I’ve investigated your service and don’t see an issue; it seems straightforward.

I see that you are using API Gateway as the provider - can you update the API policy, to store the request and response payloads and see if there’s any issue in them?

Regards,
Kasi

Thanks for investigating kasi. I believe i can’t update the policy of the API, as i am didn’t have the access to it. My senior said that if i can hit it in the postman and returns the response, it must be something wrong with the service. But i dont know where to fix that

It could be an IS or built-in service issue and it would be easy to check if you can get your API GW team to help investigate. Alternatively, check if you have installed the latest fixes and then open a support ticket.

KM

What is API GW team kasi?

I meant the team that supports your API Gateway environment.

KM

I will ask to them about this.

Do you think the problem that cause this is because of the " [ " and " ] " character are in the response? I don’t really know if that would intervene the bytesToString service

Is there anything that i can do to resolve this? do you think it might word if i add the value for “encode” field in bytesToString???

You can try setting UTF-8 as the encoding. Do you have any Indonesian or any other language-specific characters in the response? If yes, then you will have to use the appropriate encoding for that language.

You confirmed that the response JSON (from your Postman) is valid. We’re speculating now without much to go on - create a support ticket via Empower to get this issue investigated.

Suggestion - Try using “stream” as the loadAs option and see? There’s a streamToString service available.

KM

1 Like

Maybe I’m late to the party, but UTF-8 should be quite comprehensive covering most languages.

Regarding

Another alternative is to take the input JSON string , pass that to stringToBytes , pass the output to bytesToString again, check if you see a difference.

Not only related to this question, but having a cloud environment (with a set of products installed) where flows can be created and demonstrated should reduce the to and fro in such issues. If someone doesn’t want to share with public , sanitization /appropriate ACLs can be applied as well.

It will be much easier to share flow snippets that way and will allow others to look at the flow and respond.

Regards,
Nagendra

1 Like

I believe it all is in english, Kasi.

I’ve tried to set it as UTF-8, and it doesnt work

About the streamToString service, it doesnt available at my WmPublic Package

It should be in the pub.io folder by default.

1 Like

Ah just seen this, thanks, i’ve tried it, and it doesnt work… again
image

This is the flow
image

Check your fixes and create a support ticket, @Ghifari17.

@Nagendra_Prasad_A_R, yes UTF-8 usually does it, but I did have problems a few years ago while dealing with Chinese characters and had to use a specific encoding. I also tested string to bytes and viceversa, no issues on my 10.5 wM setup.

KM

I agree , while creating a ticket , having a standalone package which has the inputs to the public service, and the expected results , would speed up resolution.
-NP

To create a ticket, i need to request an account first right? i can’t use this account there?

You need an Empower account, with your work email address. Reach out to your supervisor or the wM administration team - they should already have one for a few contacts in the organization.

If you are a contractors or service provider to your wM customer, reach out to the customer to create a ticket with their Empower account.

KM

1 Like