Broker server in error state

Hello,
i found broker server running HP-UX on webmethods 6.1 server in Error status.
can someone please tell me what could be the reasons?

:confused:

How you realized the error occur? Please check the broker server log files that located in webMethods/Portal/broker/logs to get the information.

You also can start the broker server in debug mode. To do so, start the Broker Server from the command-line prompt using the following command: <webMethods_install_directory>/Broker/bin/awbroker –d <full_path_of_BrokerServer_data_directory> -blah

Example:
/opt/webMethods/Broker/bin/awbroker –d /var/opt/webmethods/awbrokers71/default -blah

Hi I have tried to start broker server in debug mode also but it didn’t started , even no message displayed after executing the command.

usually we get the output as
eux630{wmadm}# awbroker -d /EAI/wmadm/webMethods6/Broker/data/default -blah
Corefiles: “core.10951”.
Locale character type is C.
Using builtin major message catalog.
#1000 Broker Server ready, process id 5605 (Version 6.1.0.3.135 072707)

  • above broker i have started in debug mode but for some other IS the broker server is not getting started.

Hi ,

when tried again to start broker in debug mode i got below error:

eux930{b2badm_b2bi-dev_unset}$ awbroker -d /log_recv/broker61/data/default -blah
Locale character type is C.
Using builtin major message catalog.
#1229 Error: The Server cannot initialize config session with URL “qs:///log_recv/broker61/data/default/Broker.qs”. Error code 1100: QS (-2) LOCKED(QS-2) source:qs.cc line:187: Permission denied. [EXITING]

Hi rgills,
This looks like an authorization problem on the affected machine.
Pease check if the username is set to root in awbrokermon.cfg:
monitor-username=root
monitor-groupname=root