Broker server Errors

Hi All,
Urgent help needed, i tried to create another broker server at 6850 apart from my default@6849.it has created New broker server, but following message is shown up:

Error: the following Exception was thrown: the operation failed due to an unknown command in the protocol.

Broker Server Information

Name - RENU:6850
Port - 6850
Description -
Status - Good
SSL - Secure Socket Layer is not licensed on this broker
Access Control - Not accessible, Identity required
Connections
Version - 6.1.0.3.37 122804
Created -
Running Since
License Expires

can any one help me to get solved… Please

Regards
Renuka

Renuka,

I’ve not seen that error message, but I do know you cannot have broker servers on ports that close together. We have implemented SSL on our broker servers and in the broker doc there is information which states the broker uses the port-1 and port-2 ports for SSL - i.e. your default port is 6849, so 6848 and 6847 are reserved for SSL use.

Since your new broker server is on 6850, it wants to reserve 6849 and 6848 for SSL. My guess is that is the cause of the error.

Delete the 6850 broker server and create it at a new port with enough ‘space’ inbetween.

Regards,
Ray

Hi Ray,
Thanks.
Actually Ray, I had Installed Webmethods i could able to CREATE BROKERSERVER @ 6849 , because it was fresh copy on that system. But when i uninstalls it and reinstalls the webmethods software and if i try to configure broker at 6849 , i will not create at default port, it gives above mention error and ask us to specify another port.

What i want now is, After i reinstall Webmethods , i want to create broker server same at 6849 port. which i am not able to.
Please help
Thanks

Renuka,
Ray is correct about the port range. I’m guessing that your uninstall is not completely removing the broker config and data files? Go to the broker data directory and make sure it is all gone. Also make sure the awbrokermon process config file doesn’t have a reference to it. You can also you just try and install in a different directory along with a different port range.

markg
http://darth.homelinux.net

Renuka,

I agree with Mark, sounds like the uninstall did not ‘clean up’ everything…

Regards,
Ray

Hi,

please remember that port 6850 is the default port for the Broker Monitor (awbrokermon) process, which should not be changed.

Regards,
Holger