Broker not getting connected

Hi i’m getting following error while configuring my broker “BrokerPoller encountered exception:com.wm.app.b2.bserver.dispatcher.exeception.transportException:[ISS.0098.9014] BrokerException:Unknown Broker Name: No Broker by the name ‘Broker # 1’ was found on localhost:6849”
Even when i try to access the WmBrokerAdmin, over there it shows my localhost connected and i hve even checked the status of my broker which doesnt show any errors but only my IS server doesnt show as connected, i hve also checked the services on windows, they are running. Any help would really be appreciated. Thanks.

(Settings --> Broker -->Edit Broker Settings -->Selected “Configured” radio button and saved the changes.

My Broker is running in the same machine where IS is running (both localhost and port “6849”)

Hi Leon,

This worries me a bit :
“My Broker is running in the same machine where IS is running (both localhost and port “6849”)”
Probably obvious for you but IS cannot be running on the same port as Broker. Default port for IS is 5555.

Otherwise it could be a reference/name pb. In the broker settings, can you try to put the server name instead of “localhost” ? The IntegrationServerAdminGuide.pdf says in ch6 “Configuring the Server to Connect to a Broker”:
“Broker Host : Name (DNSname:port or ipaddress:port) of the machine on
which the Broker server resides.”
The IS may not be able to translate localhost to the DNS name or IP address.

HTH,
M.

Hi All,
I am getting the same error what lewis was getting. What is the solution for this. The following is the error:

2005-07-06 17:13:18 GMT+05:30 [ISS.0098.0062E] BrokerPoller encountered Exception: com.wm.app.b2b.server.dispatcher.exceptions.TransportException: [ISS.0098.9014] BrokerException: Unknown Broker Name (223-1460): No Broker by the name 'Jhelum@blrkec41010d ’ was found on host ‘blrkec41010d:6849’.

My broker server is started. I am able to ping the broker host from my integration server box.

Regards,
Pradeep.

Pradeep did you configured the broker on IS admin ? And can you able to go to the WmBrokerAdmin page?

Hi Leon Lewis,

I was getting the same problem like you. What I have done was

Go to ‘WmBrokerAdmin page’ click on:

localhost->Brokers->Create Broker on localhost

Create a broker with Valus:
Name: Broker #1
Description: Default Broker(You can describe what ever you want)

and then restart the IS, which solved my problem.

GoodLuck,
Vijay

Hi All,
When i am submitting large doc through ( 100MB) Broker I am getting this error , we r working on wM6.5 Error statement is wm.prt.status:trigger detected Endpoint Unavailable. Going into a wait state.

Any Ideas

Thanks

Pidugu

Hi Follow below process to see broker is Dead or Alive:

Go to My Computer – Manager - Service - Check Broker server is Runing or Not ?

Use below command to chk broker is Alive or Dead !

C:\webMethods712x\Broker\bin>broker_ping IP : broker port
PING Broker #1@IP:Broker Port
Broker #1@IP:Broker Port is alive

IS Admin localhost:5555 Pg – Configure Broker Setting – Add below setting

Broker Host IP (localsystem):broker port
Broker Name Broker #1
Client Group IntegrationServer
Client Prefix pGUK3wyIqAdGB7vGVBR0bdaWESI_
Use SSL No
Connected Yes

Restart the IS once you done your broker setting.

RJ–

Hi,

You can view the status of brokers using command line of broker_status "Broker@server:port_number" to check on the brokers in UNIX and Windows enviroment. The command can be found in the bin folder of the broker directory of Integration Server path.

It will show you statistics such as broker status, document delivery statistics and client statistics. You can refer to Broker_Administrator guide under the section of broker_status for more details.

Example of the broker status command is as followed:

D:\webMethods\wm712\Broker\bin>broker_status “Broker #1@localhost:6849
Version on Server “localhost:6849” is Version 7.1.2.0.78 091208
Status of “Broker #1@localhost:6849
Territory:
Current time 05/27/2010 15:31:02.220
Creation time 03/15/2010 16:37:24
Number of clients 68
Number of document types 111
Total documents published by broker 0
Total documents published by clients 14,661
Total documents delivered by clients 747
Total documents queued for clients 28,607
brstats.eventLogLength 0

Regards,
William Choong

I have follow above things but I am getting unknown command in Protocol.