Broker Doc Type changes after sync

Hi all,

I’m trying to publish 9 documents to the broker which have the following namespace (example):


But when I publish them to the broker they end up being


So, basically it’s adding an _1 on the folder name. Why does this happen? I didn’t have any previous version of these documents in the broker and I don’t have any other package with that folder as root! Really weird stuff. This worked on my local IS, but when I published it to the Development IS it just gave this error. Bogus.

Thanks beforehand!

Update: Found out that the Broker Doc Type in the developer also shows up with the “_1”. How odd is that? Maybe it was in the way I deployed the package to the DEV server?

I just exported the package using my local IS and Installed the release on the DEV Server. Maybe I did it wrong…

Is there anyway to change the Broker Doc Type?

Ok. Just edited every document, set Publishable to false and then to true again and that fixed it.

(The best threads are the ones where you find the solution for youself :rofl:)


Their is nothing weird about this. This is expected. You already have broker document type with the same namespace on the broker. when you have change the IS document type and sync it again, broker will append _1 and create another broker doc type.

To avoid this, you will have to delete broker doc type first before synchronizing modified publishable IS document.

Hope this helps.