Broken links when using front end web server

This is happening with MWS 8.0.1. It could be common to other versions as well.

We are using WebSEAL in front of MWS to provide HTTP header authentication and we have a junction set up at http://server:80/am (WebSEAL) which points to http://server:8585/ (MWS). This works for most cases, however, many links seem to reference “/meta” which is being sent to WebSEAL as http://server:80/meta which does not exist and should be going to “http://server:80/am/meta”. We have configured the front end URL of MWS to be "http://server:80/am " but this has not worked. How can we resolve this issue?

More explanation:

The /meta is appended as expected for links in HTML pages being sent back from MWS. For example, when we use MWS directly (http://server:6585/), without going through WebSEAL, this (correct) link is generated on a page

which takes us to:
as expected.

However, when we use WebSEAL ( this link is generated the same way:

Which takes us to

instead of the correct (note the missing “am” in the above link):

We have used aliases to solve some of the link issues, however we cannot do this for the webMethods internal pages. As an example: If we log in as a user with System Administrator access, we visit the User management page and open a user. Then, if we click cancel, we are given the same error.

I have had a look at the web.xml and portlet.xml but don’t see anything there that is helpful. Also, editing these files is probably not an option with the webMethods internal pages.

Any inputs are highly appreciated.

I’m sorry, but i don’t fully understand what the purpose of the URL translation is. I know you tried to explain, but could you try again please?

Why do you need to translate URLs?

Hi Mark,

Thanks for your response. I’ve also posted this in our RnD-CAF-SWAT and got response from GCS.

The summary given was:

, you cannot configure MWS to not use root URLs (actually it is not MWS, but the Noodle Shell).

But you can configure WebSEAL to redirect special root URLs to MWS. This should not be a problem, because it is unlikely these root URLs are used by any other application. At BBVA we started this way; in the end we did not finish it because of other priorities, but it looked like it would have worked in the end. They should configure at least the following root URLs in WebSEAL, to redirect to the MWS junction:
/?method=* . If they cannot use wildcards here, we found at least the following URLs were being used by MWS:

There may be more URLs, but in this case the browser will raise errors, and by analyzing the error information you can discover the URL.

I’ve one more question: How to import the JSF 168 Hello World sample in to the designer? This is not getting recognized as CAF portlet. When I enable the legacy portlet option, even then, its not getting recognized.

The purpose, is to import this sample and deploy it to the MWS 713. Your inputs are appreciated.


You don’t need to import that sample into Designer in order to deploy it to MWS. You can build it by using the MWS/mycomponents/ script to build (and deploy) your 3rd party component.