awbroker service not starting


 Folks at another site running WebMethods 6.1 under mostly the same config as myself recently experienced a hardware failure and their IT management folks did a restore that left some key directories and files notably absent.  At that time, when they tried to start the broker server service (the broker monitor service would start successfully), they received an error in the event log stating the service terminated with service-specific error 2, EventID 7024.  After discussions, they tried reinstalling the webMethods 61 software.  Now, instead of service specific error 2 in the event log, they receive service specific error 3, EventID 7024.  I compared their broker configs and registry settings to my own, and they match; all the pathnames are correct.  The Integration Server and Broker monitor servers are once again running without error after some tinkering on my part, but not the broker server itself.  I hesitate to delete it entirely and reinstall from scratch, since the vendor who supplies us with support for the application hasn't yet been able to tell me all its integration information will be correctly saved and reconfigured upon the fresh installation of the software.  Any ideas?  Where can I get the information on the service-specific error codes?