Assigning an OAuth Scope to an OAuth client timing out

What product/components do you use and which version/fix level?

IS 10.3, on a QA environment

Are you using a free trial or a product with a customer license?

Product with a customer license

What are trying to achieve? Please describe in detail.

Assign an OAuth scope to a OAuth client in an IS playing as an OAuth Autorizer.

This works fine in PROD but does not work in the QA env.
PROD and QA are almost indentical: they both are clustered, they both uses their own TSA instance.

Do you get any error messages? Please provide a full error message screenshot and log file.

No error message at all - neither on the page nor in the server.log or in the wrapper.log. The page where such assignment is done (IS Admin > Security >OAuth, Scope Management, Associate Scopes to Clients (oauth-scope-client-associations.dsp)), after clicking on the “Save Changes” button, the page just waits for a timeless seconds (for sure, more than the usual time, and then … the connection breaks.

The list of attempts:

  • performing the assignment on the other IS (also member of the same cluster): no change, same behavior;
  • tried different browsers (Chrome and Edge): no change, same behavior;
  • restarted the whole thing (shut down the two IS and, afterwards, shut down the whole TSA, and starting them again): no change, same behavior;

The odd thing is that this used to work before, we’ve used this in the last 15 months, and it was working, and currently I’m out of other ideas on how to troubleshoot this. Has anyone faced such issue?

I got this solved by recreating the the oauth client from scratch (deleting it and recreating it).

Why this glitch happened? Honestly, no [thin] idea…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.