AS400 error - Command not found in configuration

Hi Everyone,

I have two servers and I have scheduled a flow service which will run in any of the servers everyday. In one of the servers, the service runs without any error. But in the other one, it throws the below error.

wm.as400.WmAS400Exception: AS/400 Alias : Command not found in Configuration

Even though all the configurations and commands are same in both the servers. Kindly help. It would be really helpful.


Are you getting this error for every scheduler service run ? Any other details ?


No… Not for every run. But in one of the servers if it runs, it always fails.

In both the servers i have the same command configured.

If you don’t mind, can you share the command


Do both users on different serves have same access level ?


Its a policy violation. Sorry i cant share the command.

Thanks for your replies. The issue is fixed by replacing the AS400 jar files, restarting the server and recreating the AS400 adapters.

Glad to hear, issue got resolved. No worries, sometimes we get more clarity on the issue by seeing a couple of things.


Enthusiastic to know, how come jars got corrupted ? Any reasons for it ?


No clue… I was just comparing all the configurations on both the servers. Just tried this and luckily it worked. :smiley: