AS400 Connectivity through JDBC Adapter

Hi there,
Iam a new member at wmUsersForum, I have a query. Please answer thsi asap.
Iam trying to connect to the AS400 DB from my local IS server.
The connection paratmers are right in place , with the Datasource class as

Iam using JDBC 6.0.3 adapter.

Other Connection parameters are correct.

Whenever I try to enable the adapter it gives me the following error.
Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource ME005_APS_JDBC:Conn1.[ART.118.5063] Adapter Runtime (Connection): Unable to start connection ME005_APS_JDBC:Conn1: after 1 attempt(s).[ADA.1.204] Cannot connect to the database with DataSource class “”.The application requester cannot establish the connection. (beeth011)

I fail to understand the error because same adapter connectivity works fine when connected from the Dev environment works fine.Please suggest the solution.

  • Sandhya

what did you set in “portNumber” and “Other Properties” fields? Also ensure that this is not a f/w issue?

Or a mistyped password?

We do not give the database name nor the port number nor the n/w protocol when we make a connection to AS400 , they are al blank.
Regarding the Other Properties I gave “translatebinary=true;extendeddynamic=true;naming=sql;prompt=false;libraries=JD$DD, JD$SEC”
This is a correct parameter.

Finally I solved the problem of connectivity through JDBC Adapter , the problem was with the Server Name . I had to mention the full path of Server Name. It worked.