Adapter connection to SQL Server database

Hi All,

I’m getting the following error while connecting to SQL server using JDBC adapter using XA Transaction.

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource personal.rk.customer.jdbcConnections:rlngCustomerXAConnection.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “”.
[Microsoft][SQLServer 2000 Driver for JDBC][SQLServer]Could not find stored procedure ‘master…xp_jdbc_open’

When I tried to connect using Local Transaction with the same set of paramters. I’m getting no errors. I want to use XA Transactions in my interface.

Please someone help.


Hi satya,

make sure you have placed the right files at the right position.

like, u need to place the file called… which is inside \webMethods6\IntegrationServer\Packages\WmJDBCAdapter\code\jars----into


Also, do make sure that files titled :msbase.jar, mssqlserver.jar and msutil.jar are also in \webMethods6\IntegrationServer\lib\jars.



Did you check your properties for trailing spaces?

If there are any trailing spaces in only one of the properties, the DataSource is unable to build the connect-string correctly.

Please doublecheck your oracle version against the driver-jars version.

Can you please provide Connection Settings?

Have you tried setting on your IS.