Access denied to invoke the service through FilePolling

I’m doing sample scenario on filepolling.I configured all the requirements like Package Name,Monitoring Directory,Processing Service,etc…
In security i gave ‘Administrator’ in “Run service as user” tab.
The service i have written is not invoked when i get the file in to this monitoring directory.
I’m getting this following error…
" Listener FilePollingListener:C:\FilePoll was denied access to service FilePoll:filePoll "
" File polling processing service access denied. User Administrator not allowed to run service FilePoll:filePoll "

Thanks in Advance,

Verify that the ACL on the service is set so that Administrator is allowed to execute the service.

Thank you for ur response.
I have set the permissions on the service as Administrator.Still i’m getting the same error.

Edit the ‘Access Mode’ feature in the file polling service.
Add the flow service you are invoking in the allowed list.


I have already edit the Access mode to deny by default.And I have added my service also.
It is showing the same error.

if you have the access level as “deny by default”, in that case you need to add your service to the allowed list.
Otherwise you can set the access level to “allow by default”, which gives access to all the services.

Thank you for ur reply…
Now I’m getting the another error which is " Error processing service: [FPL.0002.0004] Server Error: [ISS.0086.9020] C:\FilePoll\sample.txt "

Thanks to All…
Now It’s working…