Unable to connect to Oracle

Hi,
i’m using JDBC Adapter to connect oracle d/b.
I’ve given correct DataSource URL: oracle.jdbc.pool.oracleDataSource.

But it’s saying invalid URL.Unable to connect oracle9i with the specified url.
I copied classes12.jar in respective directory of Integration Server.
With the same properties, it was worked out on other machine but mine.

Any idea.please welcome.

Thanks,
Ganesh

Ganesh,
Try using the following URL:oracle.jdbc.pool.OracleConnectionPoolDataSource. We are using Oracle 9i and the above URL works for us.
HTH…

Thanks,
Puneet Verma

No Puneet.Even then also getting the same problem:
Please see the error trace:

Error encountered

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource NewConnection:jdbcon.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleConnectionPoolDataSource”.
Invalid Oracle URL specified: OracleDataSource.makeURL

Please let me know the your ideas.

Thanks,
Ganesh

Ganesh,
Just check if you dont have any additional space after the URL name.Just strip it if you have because sometimes while copying the name, space gets added.Also check if you have the same classes12.zip as in your DB.

HTH…

Thanks,
Puneet Verma

No.Puneet not like that.
I checked it.Both things are looking fine.
Any other ideas please.

Thanks,
Ganesh

Ganesh,
Can you let me know the Connection settings and JRE you are using.Also check if the classes12.zip is showing in About page of Administrator screen.Try searching on the forum for different results for this error.A lot of posts for JDBC Connection error are posted on this forum.You can search those too.

HTH…

Thanks,
Puneet Verma

Ganesh send us your connection settings and JVM version. And as u mention that on the other machine it is working, is it on the same unix box or different.

Hi Puneet and Taz,

Both are on the same Box(Windows xp).
There is j2sdk1.4.0_02.
How can we find out which version of JVM/JRE webmethods is using?

Please have a look at my connection settings:

JDBCAdapterServicesracle_Connection Details
Connection Type JDBC Adapter Connection
Package Name Samples
Connection Properties
Transaction Type LOCAL_TRANSACTION
DataSource Class oracle.jdbc.pool.OracleDataSource
serverName DT2759-Ganesh
user scott
password ******
databaseName oracle
portNumber 1521
networkProtocol
Other Properties driverType=thin
Connection Management Properties
Enable Connection Pooling true
Minimum Pool Size 1
Maximum Pool Size 10
Pool Increment Size 1
Block Timeout (msec) 1000
Expire Timeout (msec) 1000
Startup Retry Count 0
Startup Backoff Timeout (sec) 10

Awaiting for your solution

Thanks,
Ganesh.

Ganesh,
you can find the JVM version webmethods is using by going to About Link in the Administrator screen.Also check if it shows the classes12.zip over there in About screen(you have to place it in <is_root>/lib/jars and restart the server).Try giving IP address in your server name.Other things look fine to me.

HTH…

Thanks,
Puneet Verma

Can you try to tnsping oralce from command line and verify your server name and port is correct?

Ganesh it is recommended to to use classes12.jar for JVM version 1.2 and 1.3 and classes classes111.jar for 1.1 version but for 1.4 jvm version use ojdbc14.jar, place ojdbc14.jar in IS_Directory/IntegrationServer/lib/jars and restart the server.

HTH…

If you are running your Oracle db on windows, try to restart oracle and listner services.

Thanks to all.
It’s working fine now.
Oracle listener service was stoped.
I restarted the service.

Thanks to all
Ganesh

Ganesh,
I am having the same problem and I have tried the above solution. I am not able to configure even the jdbc pools . Can you please post me the details of how you got rid of your problem.
I am having 6.1 on win xp
oracle 9i
i have ojdbc14.jar

Kris,

Did u copy classes12.jar file on your
%webMethods_Root%IntegrationServer\lib\jars folder.
You can get the jar file from Oracle_Root%\ora92\jdbc\lib.
For more details go through the webMethods_JDBC_Adapter_Users_Guide_6.0.3.pdf file.

Ganesh

Hi Kris,
Besides above mentioned settings try
oracle.jdbc.pool.OracleConnectionPoolDataSource as DataSource Class

Regards,
Puneet Saxena

I have the classes 12.zip in my integration server folder as you mentioned and I tried using the oracle.jdbc.pool.OracleConnectionPoolDataSource as datasource. I am able to0 configure the Jdbc adapeter connection now. Can some one pass me thevalues for the jdbc pools. I have run the scripts as well as have the Tn fix 13 and 15 in place. Using oracle driver I am not able to connect I am getting a 12025 exception.
Thank you for the responses

Try these values…

Associated Driver Alias: DataDirect Connect JDBC Oracle Driver
Database URL: jdbc:oracle://servername:port;SID=sid
User Id: xxxxx
Password: xxxxx
Minimum Connections: 1
Maximum Connections: 10
Idle Timeout: 60000 milliseconds

Kris,
What is the exact error you are getting.Also did you check if your Listener service is up in the Services to connect to Oracle.Check the Oracle connection with SQL Plus.
Also check if the jar files are showing in the About link in the Administrator screen.

HTH…

Thanks,
Puneet Verma