node name $any is not working in service pub.scheduler:updateComplexTask

HI All,

I am trying a service to move scheduler node to new node and all valid values are working fine other then ‘any’ , I also tried ‘$any’ but still not working.
pub.scheduler:getTaskInfo service gives ‘$any’ target node when used for a scheduler running with config node as any.

Please help.


You are trying to setup a scheduler in a IS cluster environment configured?

Any errors you noticed in the logs?

Is the Clustering page shows expected 2 nodes up and discovery ip’s?

So I assume they are on accessing same JDBC pool (IS Internal) right?

Please check the above inputs.


Whatever you said is correct.
The error I ma getting is “invalid node name”.

Scheduler shows all nodes in cluster on IS console , and I am successfully able to change node from one to another ,and $any or $all to any specific node.

Only while changing to $any or any is not working. It says invalid node name but documentation says the value of node is ‘any’ is you want to update scheduler to run on any one node in scheduler.

Did you check the DB table for the UserTasks and make sure what is going on>

What is your IS version and fix levels?

Did you check with SAG support also?


I am trying this on 7.1 ad 8.2 both.
7.1 IS has IS_7.1.3_Core_Fix17 installed and 8.2 has IS_8.2_SP2_Core_Fix5 and IS_8.2_SP2_Core_Fix6 intsalled.

I havent checked with SAG support yet.

Please check with SAG support and it should be related to either IS core fix levels or clustering issue on 822

In case you get any out come result from them, please update this thread it will be helpful.


There is one related fix, however it is for 7.1.2. If you have same problem happening in 7.1.3, contacting SAG support is the best that you can opt for…

1-1XAJUD (IS_7-1-2_Core_Fix8)
Attempts to create a scheduled task to run on another server in a cluster result in error [ISS.0085.9234] Invalid target node.

In a clustered environment, if a user on one Integration Server tries to schedule a task to run on another server in the cluster, the following error is issued:

Error updating task: [ISS.0085.9234] Invalid target node
This problem occurs because the scheduler expects an unqualified target host name, but receives a fully qualified host name instead.

This issue is resolved.