Location od dtd files on IS server

Hello forum,

I am working with a customer who will send us XML files via HTTP. The doctype line in their transmissions looks similar to this one:

Now they sent me the Report_PO.dtd but I don’t know exactly at which location(s) I have to put it on the server and/or client so that it can be found when I process the files (a) by running a flow service on a client in Developer for testing and (b) through having the service automated and running on the server as the http transmissions are received.

Every time I run it in Developer right now I get an java.io,FileNotFoundException: Report_PO.dtd (The system can not find the specified file).

I understand that when SYSTEM is used and then only the filename without path information that it will look in the “current” directory. So where is that for those two scenarios? I tried putting it on the IS server at a couple of different locations and I also tried it on the CLient PC from where I run Developer.

Is there a configuration then in the IS conif files where I can set the directory path for the default location?

We are using IS 6.5.2 installed on Windows 2003 Server. Client is Windows XP.

Any help is much appreciated. I have searched the forum here and at wm website with searches like “dtd location” “SYSTEM dtd” etc but so far have not found an answer to my question.


How are you processing the file? By default, the IS ignores schema and DTD declarations and does not validate the file until expressly told to (such as in a TN doctype or via pub.schema:validate).

On the other point, the default home directory for the IS is IS_DIR, which is typically set to /webMethods6/IntegrationServer. This can be altered with the HOME parameter of server.sh or server.bat.

But let me know how you are processing the file that causes it to look at the OS for the DTD and perhaps I can actually be of help. :slight_smile:


thank you for your quick response. Boy, I really was not with it this morning when I posted the message. First I had a typo in the title of the message and then I forgot to mention the flow step where I get the io error.

Ok here goes right now in development stage I first do a pub.file:getfile and then a pub.xml:xmlStringToXMLNode. The error occurs during the next step when I do pub.xml:xmlNodeToDocument.

And guess what I just put the file in the IntegrationServer directory on the server and it WORKED… thank you so much.

Looks like my problem is solved!

Thanks for taking the time to answer.


Glad it worked for you!