Error with gadgets when the remote connect to BC

Hi Experts,

I have a problem. When I connect to BC with localhost, all gadgets are loading. If I connect remotely to BC, some gadgets aren’t loadign to end. After clicked button “Refresh” problem isn’t resolve, and appears message “Error Unable to invoke RESTful call to webMethods Business console”.

On the next image shows, how gadgets look like all time, when I connect remotely to BC.

How I can resolve this problem?

Best regards,
Dmitry.

Hi Dmitry,

Can you please share the screenshots of the Chrome Developer tools when you face this issue, please send the screenshots of the network call and the errors if any.

Regards

Vinay

Hi Vinay,
Thank you for responding.
I did everything as requested. If I understand you correctly.

Best regards,
Dmitry.


Another screenshot

Best regards,
Dmitry.

In the previous screenshots, I forgot to enable UM.
The following screenshot was taken after turning on the UM.
Please look at the last screenshot.

Best regards,
Dmitry.

The screenshots are not very conclusive, there seems to be some connectivity issue or the hostname configured is not correct, can you please also share the screenshots from the “Administer Business Console UI”.

-Vinay

I understand correctly?
Should I change the URL for IS and Task Engine to the URL I use for remote connection?

Yes please try changing the URLs to the Remote Host urls in the Administer Business Console UI.

Vinay

Thank you.
I change URL.This solved my previous problem. There is another problem.
In a Work Stream I don’t see nothing. Task Engine installed. May be you know why?
More information is in screenshot.

Best regards,
Dmitry.

Can you please share screenshots of Chrome Developer Tools Network Tab after you made changes to URL settings.

Yes of course. Thanks for your help.

Best regards,
Dmitry.