Disable Datahub docker container in Edge

Dear Team,

I have try to install datahub in my local thick edge, the installation is successful.

But for limit resources for my laptop, the response of edge is very slow now . How can I disable all containers named cdh-* in edge.

I have try run ‘docker stop’ & ‘docker rm’ to stop/remove the containers, but these container will auto restart after minutes.

I also try update the restart policy for the container with command ‘ docker update –restart=no’. but not working.

below commands have been try, but fail either.

sudo service cdh-master stop
sudo service cdh-executor stop
sudo service cdh-console stop

I think ‘monit’ is configured the way that is restarts services that are stopped. That means you have to disable monitoring of the services cdh-* via monit:

sudo monit stop

Hi @Murat_Bayram ,
The monitoring for the services cdh-* is available to stop now .
Further question, how to disable these monitor at all ? The monitors will be re-active after vm reboot .

I guess its unmonitor

Before stopping theservices you should stop monitoring specifically for them using

            monit stop cdh-console
            monit stop cdh-master
            monit stop cdh-executor

Best regards,

the command ‘monit unminitor <service_name>’ not work.

The service will be re-active after reboot.

If you want that disabling of DataHub survives also a reboot, DataHub needs to be uninstalled at least partially.
The following steps need to be executed as root user:

monit stop cdh-console
monit stop cdh-master
monit stop cdh-executor

service cdh-console stop
service cdh-master stop
service cdh-executor stop

rm /etc/monit.d/cdh
monit reload

rm /etc/init.d/cdh-console
rm /etc/init.d/cdh-master
rm /etc/init.d/cdh-executor

docker rm -f cdh-console cdh-master cdh-executor
docker image rm cdh-console cdh-server

If you want to re-activate DataHub at a later point in time, you need to re-install.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.