"Device registration request with ID already exists" error when trying to register ubloxC027


I am trying to register my mbed ublox C027 on cumulocity via device registration.
I entered IMEI number, and pressed next; but I am presented with below error:

Failed to register device.
Device registration request with ID xxxxxxxxxx already exists.

I have tried searching through the registered devices, but I do not find any device with similar IMEI number.
Also there are no pending registrations in device registration portal.

I have also tried factory resetting as mentioned here.

Can you please suggest how can I proceed.

Details of the error:
“error”: “devicecontrol/Non Unique Result”,
“message”: “NewDeviceRequest for id = 359739071290449 already exists.”,
“info”: “https://cumulocity.com/guides/reference-guide/

I believe that the Client ID used when doing the registration must be globally unique.
Perhaps someone used a number the same as your IMEI.

Hi Hitesh,

John is right. It looks like the device is registered on another tenant. Where did you get the device from? Maybe you can contact those persons to unregister the device from its previous tenant. Also do a factory reset of the device before trying again.

best regards