ComsapmwjcoJCO%24Exception Type conflict when calling a function module

Hi all.

I am testing the service that I’ve created in webMethods which does the following:

  1. Open and reads a file.
  2. Call SAP RFC to pass the file and create credit requests in SAP.
  3. Receive message from SAP and send email to users.

My problem is, it is failing on my RFC. I managed to test it yesterday but when I tried it again today, I had this error:$Exception: Type conflict when calling a function module.

The only thing that was changed was I added some more validation codes in SAP but the RFC parameters were not changed.

We are in R/3 Release 4.6C and webMethods Version 6.0.1

Thanks in advance.


Hello Miles,

Faced a similar problem sometime back.
I renamed the Function module in SAP and it worked. Maybe it will work in your case also.


If the RFC signature has changed on the SAP side you must clear the DDIC cache (in the SAP Adapter) before using it again.

Thanks to Muthiah and Sergio. We just flush the cache and it worked!