I have created a web service connector from a good WSDL. WSDL file was analyzed in SoapScope for its validity. It was also validated in XML Spy. In Developer, while stepping through this web service connector, it throws the following exception on the flow step : pub.client.soapHTTP

An error occurred while tracing."

No any other detailed error message was thrown.

Rather running the web service connector, it throws the following error :
“Could not run ‘’.

If anyone of you have passed through the same error, please help.



I want to add more detail on this particular problem.

I doubt on the WSDL target endpoint. Target endpoint is something like:


I cannot disclose the actual values in the URL so I have used some dummy names.

hi there… is anyone know what is the problem with this error???

i’m having the same error when trying to connect to as400 server
and after i do some checking it only happen if i’m trying to step into the service
and it works perfectly if i run it using http invoke
so i think its a problem is within the developer



Hi, Normally this error occurs mainly because of the some tag conflicts in the WSDL i.e if the fields in the wsdl is not properly formatted. Check out the WSDL more minutely.

It seems that this error appears in several different contexts.

java.lang.NullPointerException at com.wm.util.coder.IDataBinCoder._encode( (…)
when running, and
when debugging.

Also, when read from the server log, it appears in this form
[ISC.0088.0001E] SOAPException: [ISS.0088.9136] A WattEvaluationException was thrown by the XQL Query engine

Reading as much as possible in Advantage about it I’ve seen solutions that range from rebooting the IS to installing several fixes.

In my case, the solution was far more simple than this. When generating the service from the WSDL spec, a call to pub.client:soapHTTP is also created. This call has a parameter, “loadAs”, which is not optional. However, the generation does not provide a value for it. Just set it to “stream” and things will go fine.