Bulk ingestion in Cumulocity IoT using /measurements API is throwing Socket timedout exception. READ TIMEDOUT. Not able to attach image here

What product/components do you use and which version/fix level?

cumulocity IoT

Are you using a free trial or a product with a customer license?

Customer License

What are trying to achieve? Please describe in detail.

I am trying to make a bulk ingestion every 15 minutes once i receive data file through Spring boot’s resttemplate. I get the read timeout. error.

Do you get any error messages? Please provide a full error message screenshot and log file.

Exception: org.springframework.web.client.ResourceAccessException: I/O error on POST request for “https://solenis.us.cumulocity.com/measurement/measurements”: Read timed out; nested exception is java.net.SocketTimeoutException: Read timed out

Have you installed latest fixes for the products

No. tried to increase the timeout setting for resttemplate in spring boot using HttpComponentsClientHttpRequestFactory.settimeout. Still getting the same error. Need urgent help how to resolve the read timeout. Is there anything to be done from Cumulocity side?


depending on the versions of the microservice SDK that you use, one of these within your properties file should work


These set the timeout to 20 minutes.


Hi Tristan,
Thank you for the response. I am running a spring boot jar that has application.properties file. Is it enough if I specify any one of your suggested timeout properties? Will it be automatically fetched while we make resttemplate call from springboot code? Or relevant to these properties set do I need to use these properties anywhere in the code? Kindly clarify.

P. Sethu pandia raja

Hi Sethu,

the application.properties files should be the right file to place this in. To be on the save side, just place both lines in there and see if it works. You can then later on check which one of these is the right one for your current version of the microservice SDK.

There is no need to change anything within your code if your using the cumulocity java microservice SDK.


Hi Software,
while publish this service i am getting error don’t know it was DB issue or not
Unable to invoke adapter service AmGlOEBSProvider.JDBC.OEBS.Project:insertXX_PA_PROJECTS_CLASSES_STG with connection AmGlConnections_GlHQ.JDBC.OEBS:OEBS_Local.


Hi Tristan,
Thanks a lot for your help. I was using the same RestTemplate Object for two POST calls. Now with two diferent RestTemplate objects it worked. Thanks for you suggestions too. I am also using the timeout properites you have given in my application.properties files too.

Thank You.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.